Author Topic: [SOLVED] Laptop Hung When Trying to Sleep Forced to Turn Off Now Won't Boot  (Read 4554 times)

Offline sweetld

  • Newbie
  • *
  • Posts: 5
Firstly, I'm a complete Linux Newbie... 8)

Basically laptop has been working fine, yesterday evening it went into sleep mode and when I moved the mouse I just had the pointer on a black screen, no password prompt, nothing. Caps Lock had no effect, no reaction to any keys, left it for 5 mins still no response.

As I needed to use it I ended up having to force a reboot (hold power button down for a long time). When I tried to reboot I got lots of numbers stream past (like register outputs or something) and then ended with:

Code: [Select]
Killed
mount: mounting /dev on /root/dev failed: no such file or directory
mount: mounting /sys on /root/sys failed: no such file or directory
mount: mounting /proc on /root/proc failed: no such file or directory

Target filesystem doesn't have requested /sbin/init

No init found. Try passing init = bootarg

initramfs:

Now I googled this and what I found is suggesting that there is some kind of file corruption (I guess because of my forced reboot  :-[) and that maybe I can replace the relevant files and get it booting again. :-\

My problem with this is that if I try to boot from a Live USB, it will never boot with the hard drive in the laptop, ONLY when I take the hard drive out! :(

So how can I boot my laptop and get access to my drive, if I can't get it to boot from a Ubuntu Live USB ??

My utmost concern here is actually retrieving my data from the drive as I have absolutely loads of very important documents and emails, not to mention photos and video (yes I know I should backup - and that was going to be my next task with Linux, finding something to back it up for me nicely - unfortunately I never quite got that far... :-[).

Please bear in mind that I have very little Linux knowledge / skill, so if you have any suggestions can you please include the commands that I should use?

Thanks for any help here...
« Last Edit: November 20, 2010, 06:19:38 AM by sweetld »

Ubuntu Forums (Ubuntu Linux Support)


Offline sweetld

  • Newbie
  • *
  • Posts: 5
Well after some careful research, I booted from a Parted Magic 4.5 Live CD (from the cover of Linux Mag) and found that I could mount the drive in my laptop. As soon as I have managed this, I copied all my important docs, pics, emails and other info onto an external USB drive.

With this safe, I thought that I might see if I could use a drive checking tool to see what the damage was, so I simply unmounted the drive again and used fsck to check the drive. It came back clean with no reported bad blocks or errors.

I also tried the check option in Parted Magic for the partition (which seems to basically use the same utility) which also found no errors as far as I could tell.

After that I wasn't sure where to go, so I thought I would try rebooting again from my hard disk - this time, as it booted it automatically ran some kind of disk scan and repair and after a little while it actually booted again!!

I then shutdown and rebooted again, just to make sure, and low and behold it seems to have corrected whatever file corruption or errors there were, as everything seems to work :D

I subsequently found a couple of files that are corrupt, but only a couple and luckily nothing very important, so I am hoping that everything else is OK, it certainly seems to be!

So I'm off to find a decent backup tool, so far I have only found Deja Dup, which is OK, but not great as you have to restore from a whole day's backup. I really would like to be able to restore single files or directories that I want, as well as to restore everything if my drive goes completely south one day... ;D