Author Topic: Nvidia GeFroce 5200 xorg.conf problem Ubuntu Hardy  (Read 2237 times)

Offline agelols

  • Newbie
  • *
  • Posts: 1
Nvidia GeFroce 5200 xorg.conf problem Ubuntu Hardy
« on: January 21, 2010, 09:56:22 PM »

Hello
I've been using ubuntu Hardy for some time now but i am still a useless newbie(forgive me for that). a while ago while trying to fix something with my keyboard layout i followed another forums advice and ended up using the
sudo dpkg-reconfigure localepurge
command in order to configured the localpurge(that didn't go really well)and ended with not being able to pick another layout from the System-Preferences-keyboard option.that wasn't the worst thing to happen, my Nvidia also wasn't working, i installed the drivers again and i am up to the point where my computer has Nvidia enabled under the Hardware Drivers option(System-Administrator-HardwareDrivers)
while my resolution is stuck at 800x600.
I've allready installed the Nvidia X Server Setting Option with the
sudo apt-get install nvidia-settings
but i get the error:
You do not appear to be using the NVIDIA X driver.
Please edit your Xconfiguration file(just run nvidia-
xconfig as root),and restart the X server.

When i run
sudo nvidia-xconfig
i get:

Using X configuration file: "/etc/X11/xorg.conf".
Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
New X configuration file written to '/etc/X11/xorg.conf'

Doing just that and restarting the X server (i do that using the ctl-alt-Backspace) doesn't really do much.


My new xorg.conf file looks like that:



# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Thu Feb 14 18:20:37 PST 2008

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "screen1" 0 0
InputDevice "Generic Keyboard" "CoreKeyboard"
InputDevice "Configured Mouse" "CorePointer"
EndSection

Section "Module"
Load "glx"
Load "v4l"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg "
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Monitor"

#
Identifier "monitor1"
Gamma 1
EndSection

Section "Monitor"

#
Identifier "monitor2"
Gamma 1
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

Section "Device"

#
Identifier "device1"
Driver "nvidia"
VendorName "Intel"
BoardName "Intel 865"
BusID "PCI:0:2:0"
Screen 0
EndSection

Section "Device"

#
Identifier "device2"
Driver "nv"
VendorName "NVIDIA"
BoardName "NVIDIA GeForce FX (generic)"
BusID "PCI:1:0:0"
Screen 0
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
DefaultDepth 24
SubSection "Display"
Modes "800x600"
EndSubSection
EndSection

Section "Screen"

#
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "nvidia-auto-select"
EndSubSection
EndSection

Section "Screen"

#
Identifier "screen2"
Device "device2"
Monitor "monitor2"
DefaultDepth 24
EndSection

i can see that the written resolution on the file is 800x600 but don't know how to tweek that,, please someone to help me with that and also if someone knows how
to get back more languages with my Keyboard layout,

thanks in advance and forgive my ignorance,cheers.
agelos is offline      Reply With Quote

Ubuntu Forums (Ubuntu Linux Support)

Nvidia GeFroce 5200 xorg.conf problem Ubuntu Hardy
« on: January 21, 2010, 09:56:22 PM »

Offline wojox

  • Newbie
  • *
  • Posts: 2
    • http://wojox.homelinux.net/
Re: Nvidia GeFroce 5200 xorg.conf problem Ubuntu Hardy
« Reply #1 on: January 30, 2010, 06:12:50 PM »
agelos, you should be able to open your terminal and run:

Code: [Select]
gksudo nvidia-settings
which will allow you to set your resolution.

Offline Je Et

  • Newbie
  • *
  • Posts: 1
Re: Nvidia GeFroce 5200 xorg.conf problem Ubuntu Hardy
« Reply #2 on: March 29, 2010, 02:36:55 PM »
You want to upgrade to Ubuntu 9.10, you don't have to,of course, but stuff like my 360 xbox controller worked right of the box.  I'm running a Dell P4 with a Nvidia 5200 and the latest drivers for it are 'NVIDIA-Linux-x86-173.14.25-pkg1.run', which I had to get from their site. The latest one I could get with synaptic was 'NVIDIA-Linux-x86-173.14.20' .  There are some special instructions you need to follow,but it's not that hard to do.