Author Topic: Problem with dualscreen after update to ubuntu 10.04  (Read 1413 times)

Offline ulrik

  • Newbie
  • *
  • Posts: 1
Problem with dualscreen after update to ubuntu 10.04
« on: July 30, 2010, 12:36:09 AM »
Hi fellow Linux users.

I have a thinkpad t61p with a 1920x1200 screen.
I also have at docking station with a 1920x1200 primary screen and a 1600x1200 secondary screen.
I use the recommend  proprietary Nvidia driver for the Nvidia Quadro FX 570M graphic cart.

All worked perfect with my current xorg.conf file, until i updated to ubuntu 10.04.

The problem is that if I start up my computer outside my docking station it starts up with a 1600x1200 resolution, where it should be 1920x1200.
When i start up in the docking station all works perfect.   
   
My xorg.file looks like this.
Code: [Select]

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildd@palmer)  Sun Feb  1 20:21:04 UTC 2009

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: xconfig, VertRefresh source: xconfig
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "CRT-0"
    HorizSync       30.0 - 94.0
    VertRefresh     48.0 - 85.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Quadro FX 570M"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option         "TwinViewXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "CRT: 1600x1200 +1920+0, DFP-1: 1920x1200 +0+0; CRT: NULL, DFP-1: 1920x1200 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection



If somebody could help me it would be great. it is really annoying

Regards Ulrik

Ubuntu Forums (Ubuntu Linux Support)

Problem with dualscreen after update to ubuntu 10.04
« on: July 30, 2010, 12:36:09 AM »