Author Topic: Lilypond 2.12.3 install broken on Natty - manually installed a later version  (Read 1122 times)

Offline maarvarq

  • Newbie
  • *
  • Posts: 3
I tried to install Lilypond (music typesetter) using the instruction on this page http://www.ubuntugeek.com/lilypond-a-program-for-typesetting-sheet-music.html, i.e. just
sudo apt-get install lilypond
and although there didn't appear to be any problem with the install

$ sudo apt-get install lilypond
[sudo] password for mark:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  guile-1.8 lilypond-data lilypond-doc tex-common texinfo texlive-binaries
  texlive-common
Suggested packages:
  guile-1.8-doc debhelper texlive-base texlive-latex-base
  texlive-generic-recommended texinfo-doc-nonfree
The following NEW packages will be installed:
  guile-1.8 lilypond lilypond-data lilypond-doc tex-common texinfo
  texlive-binaries texlive-common
0 upgraded, 8 newly installed, 0 to remove and 0 not upgraded.
Need to get 159 MB of archives.
After this operation, 433 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://au.archive.ubuntu.com/ubuntu/ natty/main guile-1.8 i386 1.8.7+1-3ubuntu3 [7,752 B]
Get:2 http://au.archive.ubuntu.com/ubuntu/ natty/main texinfo i386 4.13a.dfsg.1-6ubuntu3 [437 kB]
Get:3 http://au.archive.ubuntu.com/ubuntu/ natty/main tex-common all 2.09 [711 kB]
Get:4 http://au.archive.ubuntu.com/ubuntu/ natty/main texlive-common all 2009-11 [101 kB]
Get:5 http://au.archive.ubuntu.com/ubuntu/ natty/main texlive-binaries i386 2009-8ubuntu2 [7,386 kB]
Get:6 http://au.archive.ubuntu.com/ubuntu/ natty/universe lilypond-data all 2.12.3-7ubuntu1 [2,411 kB]
Get:7 http://au.archive.ubuntu.com/ubuntu/ natty/universe lilypond i386 2.12.3-7ubuntu1 [1,535 kB]
Get:8 http://au.archive.ubuntu.com/ubuntu/ natty/universe lilypond-doc all 2.12.3-7ubuntu1 [146 MB]
Fetched 159 MB in 59min 24s (44.6 kB/s)                                       
Preconfiguring packages ...
Selecting previously deselected package guile-1.8.
(Reading database ... 158652 files and directories currently installed.)
Unpacking guile-1.8 (from .../guile-1.8_1.8.7+1-3ubuntu3_i386.deb) ...
Selecting previously deselected package texinfo.
Unpacking texinfo (from .../texinfo_4.13a.dfsg.1-6ubuntu3_i386.deb) ...
Selecting previously deselected package tex-common.
Unpacking tex-common (from .../tex-common_2.09_all.deb) ...
Selecting previously deselected package texlive-common.
Unpacking texlive-common (from .../texlive-common_2009-11_all.deb) ...
Selecting previously deselected package texlive-binaries.
Unpacking texlive-binaries (from .../texlive-binaries_2009-8ubuntu2_i386.deb) ...
Selecting previously deselected package lilypond-data.
Unpacking lilypond-data (from .../lilypond-data_2.12.3-7ubuntu1_all.deb) ...
Selecting previously deselected package lilypond.
Unpacking lilypond (from .../lilypond_2.12.3-7ubuntu1_i386.deb) ...
warning: kpathsea: configuration file texmf.cnf not found in these directories: /usr/share/texmf/web2c:/usr/share/texmf-texlive/web2c:/usr/local/share/texmf/web2c.
warning: kpathsea: configuration file texmf.cnf not found in these directories: /usr/share/texmf/web2c:/usr/share/texmf-texlive/web2c:/usr/local/share/texmf/web2c.
Selecting previously deselected package lilypond-doc.
Unpacking lilypond-doc (from .../lilypond-doc_2.12.3-7ubuntu1_all.deb) ...
Processing triggers for man-db ...
Processing triggers for doc-base ...
Processing 3 added doc-base file(s)...
Registering documents with scrollkeeper...
Processing triggers for fontconfig ...
Processing triggers for install-info ...
Setting up guile-1.8 (1.8.7+1-3ubuntu3) ...
update-alternatives: using /usr/bin/guile-1.8 to provide /usr/bin/guile (guile) in auto mode.
Setting up texinfo (4.13a.dfsg.1-6ubuntu3) ...
Running mktexlsr. This may take some time. ... done.
Setting up tex-common (2.09) ...

Creating config file /etc/texmf/texmf.d/05TeXMF.cnf with new version

Creating config file /etc/texmf/texmf.d/15Plain.cnf with new version

Creating config file /etc/texmf/texmf.d/45TeXinputs.cnf with new version

Creating config file /etc/texmf/texmf.d/55Fonts.cnf with new version

Creating config file /etc/texmf/texmf.d/65BibTeX.cnf with new version

Creating config file /etc/texmf/texmf.d/75DviPS.cnf with new version

Creating config file /etc/texmf/texmf.d/80DVIPDFMx.cnf with new version

Creating config file /etc/texmf/texmf.d/85Misc.cnf with new version

Creating config file /etc/texmf/texmf.d/90TeXDoc.cnf with new version

Creating config file /etc/texmf/texmf.d/95NonPath.cnf with new version

Creating config file /etc/texmf/updmap.d/00updmap.cfg with new version

Creating config file /etc/texmf/texmf.cnf with new version
/usr/sbin/update-language-def: line 779: printf: missing unicode digit for \u
Running mktexlsr. This may take some time... done.
texlive-base is not ready, delaying updmap-sys call
texlive-base is not ready, skipping fmtutil-sys --all call
Setting up texlive-common (2009-11) ...
Setting up texlive-binaries (2009-8ubuntu2) ...
update-alternatives: using /usr/bin/xdvi-xaw to provide /usr/bin/xdvi.bin (xdvi.bin) in auto mode.
update-alternatives: using /usr/bin/bibtex.original to provide /usr/bin/bibtex (bibtex) in auto mode.
mktexlsr: Updating /var/lib/texmf/ls-R-TEXMFMAIN...
mktexlsr: Updating /var/lib/texmf/ls-R-TEXLIVE...
mktexlsr: Updating /var/lib/texmf/ls-R...
mktexlsr: Done.
Setting up lilypond-data (2.12.3-7ubuntu1) ...
 Running mktexlsr /usr/share/texmf...
mktexlsr: Updating /var/lib/texmf/ls-R-TEXMFMAIN...
mktexlsr: Done.
Setting up lilypond (2.12.3-7ubuntu1) ...
Setting up lilypond-doc (2.12.3-7ubuntu1) ...


when I try to run it I get
$ lilypond
GNU LilyPond 2.12.3
warning: not relocating, no 2.12.3/ or current/ found under /home/mark/share/lilypond/
ERROR: In procedure primitive-load-path:
ERROR: Unable to find file "lily.scm" in load path


Unfortunately there isn't a /home/mark/share/ directory at all, let alone a /home/mark/share/lilypond/

There's a lily.scm under
/home/mark/lilypond/usr/share/lilypond/current/scm
but I'm pretty sure that's an old one. I tried Googling the error but the nearest to relevant was talking about installing on a Mac.

Added 03/09
There is a directory 2.12.3 under /usr/share/lilypond/, and a lily.scm file under /usr/share/lilypond/2.12.3/scm, but now I'm not sure how to tell the shell to look there for it.

Added later 03/09
I added /usr/share to my /etc/environment file
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/share"
and /usr/share/lilypond to my /home/mark/.bash_profile
PATH=$PATH:$HOME/bin:/usr/share/lilypond
and /home/mark/.profile
PATH=$PATH:/usr/share/lilypond
files, and I still get the same error.

Added 10/09
I wound up manually downloading and installing version 2.14.2 (proved to be pretty simple) following instructions here
http://lilypond.org/unix.html

Any thoughts? Thanks.
« Last Edit: September 10, 2011, 08:22:42 AM by maarvarq »

Ubuntu Forums (Ubuntu Linux Support)