Author Topic: Win7 and Ubuntu 12.04 fubar after Ubuntu update and boot-repair  (Read 1058 times)

Offline Mimalito

  • Newbie
  • *
  • Posts: 1
Hello folks,

First and foremost I apologize for being the newbie whose first post is similar to others found on here. I did browse the sticky and a couple other posts, however taking bits and pieces of advice from random forums without understanding everything I was doing led me to my current problem.

Background:

I am an average/slightly above average windows user and a novice linux user. I understand the basics of linux but a lot of the terminology is still new to me.

I've had Win 7 installed on my SATA internal drive on this machine for about 5 months. 1-2 months ago I decided to play with linux but was weary of the partition process so I split an external 2TB drive in two and installed 11.10 on it.

Because I'm not really familiar beyond the basic concepts of MBR and GRUB I dual booted my machine but in a less then smooth fashion. I set my BIOS to boot first from my external drive (Ubuntu) and then my internal drive (Win7). This way I could turn on my external if I wanted to boot linux, and if I wanted windows I would simply leave the external off during the boot sequence. It never worked flawlessly but I could successfully boot into it and run Ubuntu. Some days it was all I would use.

My problem:

So a few days ago I booted into Ubuntu and was prompted to update to 12.04. I clicked away.. why not?
The update seemed to go smoothly, no noticeable errors. Upon reboot it said that there was no operating system present or something to that effect. I rebooted into Win 7 and read up on the error. Forum posts were talking about it not being a big deal and to use boot-repair on it. I rebooted again and used my Ubuntu 11.10 thumb drive to use boot-repair. After I did and successfully(?) repaired it I rebooted.

Ubuntu 12.04 was found but I did notice something new. It was giving me messages about it taking a long time to mount certain drives. If was listing a few partitions on a separate internal drive so I skipped them. Ubuntu 12.04 loaded up and it immediately saw the partitions it claimed not to anyway. I messed around with 12.04 a bit and the few personal files I had were still there and accessible.

I decided I wanted to connect my Kindle to Win 7 and put some music on it since Ubuntu said it couldn't mount it. I rebooted the machine and it now said the same thing on my Win7 install, that there was no OS found. Thing is when using boot-repair I went exploring the advanced options and I now remember listings regarding MBR and windows boot. I think I messed with one too many settings and now I can't boot into Windows or Ubuntu regardless of any BIOS settings. While I don't claim to fully understand grub and boot loaders in general I do understand the basic functions. It's my assumption that something happened on both drives and now the boot loader/s are missing/corrupt/etc and not pointing to the installed OSs.

A few things..

Windows boots directly to Windows Error Repair. Nothing I do in there helps. I can run a command prompt but it's been so long (win 3.1) since I've messed with command prompt I wouldn't even know what commands would be helpful. As in other posts I get mentions of "GPT partition style" which I'm not familiar with what this is. Also when I try to auto repair the boot it says "Failed to save start up options" and at some point mentions a missing 1mb partition I think?

Weapons in my arsenal:

Flash drive with Ubuntu 11.10 installed on it (it's how I'm on the Internet now and how I initially installed Ubuntu)
Windows 7 install disc (I've booted from this and can't fix boot)
Windows 7 backup on my external (it's an image from mid March, I don't want to use this unless totally necessary, I will loose personal files from the time in between and no saying that this will fix anything. I'm still convinced it's just a boot loading problem.)

I'm sorry for the epic story. I figure everyones story is unique and perhaps someone can help me shed some light on this. I can stand to lose and reinstall the Ubuntu, Win 7 however has a lot of the wife's homework.. /gulp

If there are any reports I can run and post please let me know. Huge thanks in advance.
Cheers!

Ubuntu Forums (Ubuntu Linux Support)