Author Topic: Neither Upgrade Manager or package manager will open on my 12.04  (Read 4960 times)

Offline fsirett

  • Newbie
  • *
  • Posts: 2
I am not having my best day. I have spent two hours trying to get the other (official) Ubuntu forum to remember me, my password, the passwords (8, so far) I have been given in the reset rmails and I have what appears to be a serious problem.

First of all, all worked well until the weekend when the Software centre would not open and stay open. I thought that was some small bug that would disappear with the next upgrade, but the upgrade manager never appeared and I thought that odd. I tried opening it manually and it also refuses to open long enough to do anything.

Now I have decided that Synaptic Pacage manager might give me a clue and it now refuses to open. I have one interesting error report. This :

E: Type 'debhrrp://' is not known on line 3 in source list /etc/apt/sources.list.d/getdeb.list
E: The list of sources could not be read.
Go to the repository dialog to correct the problem.
E: _cache->open() failed, please report.

I would love to eiminate that file, but since I cannot get to the package manager, I am not knowledgeable enough to know how to do it from the terminal; probably a good thing since I am not completely aware of what taking it out would actually so. 

Don't you all love clueless idiots who ball up their systems with their lack of knowledge and come crying to you for help? I have seen the enemy and he looked startlingly familiar!

Frank Sirett

An addendum to this post. I corrected some of the typos to make it more readable, but mostly I wanted to say I have gone to my files mentioned in the error message and cannot find a listing for that particular file that is mentioned. I admit there are a number of documents with the same or similar name, but the exact record does not seem to exist, or I do not see it. Sorry for the bother, I am trying to learn, but the fingers do not learn as fast as the brain and they seem to think they have good ideas that they do not know how to correct
« Last Edit: June 01, 2012, 08:32:15 AM by fsirett »

Ubuntu Forums (Ubuntu Linux Support)

Offline fsirett

  • Newbie
  • *
  • Posts: 2
Playing around a good bit I solved this problem. For those who follow, here is the process.

First of all, I deleted the file mentioned. This did not help much, since it was a backup file.

I changed ownership and permissions from Nautilus (as opposed to terminal.I did this by hitting alt+F2 and then typing into the "run applications" line "gkeu nautilus". I then went to the file folder and its poperties tab and changed ownership and permissions to myself. I then went back to the file and deleted the line.

The deletion was denied because I had no backup. ( I had deleated the .list.bck file so I "saved as" adding the .bck and then altered the file removing the offenting line.

Everything worked, but I was denied access to the updates for that section. They were unticjable.

I went to: and, as suggested there, I added these two lines in the terminal:

wget -q -O - | sudo apt-key add -
sudo sh -c 'echo "deb precise-getdeb games" >> /etc/apt/sources.list.d/getdeb.list'

I went back to the update manager and all worked perfectly.

I do hope this helps some. Cheers for all the help in solving this problem. I got there in the end