Ubuntu Forums (Ubuntu Linux Support)

Tutorials & Tips => Tutorials & Tips => Topic started by: RolandYoung on May 07, 2010, 11:18:12 PM

Title: Prepare partitions screen comes up blank
Post by: RolandYoung on May 07, 2010, 11:18:12 PM
I have just successfully installed Ubuntu 10.04 LTS (Lucid), but not until after two evenings searching for a solution to an issue that seems to have been baffling people for a couple of years, to judge by the forum posts I saw before I found the one with the answer.

Problem: Installing from live CD, (whether choosing to do so from the boot menu or by using the desktop icon),
At step 4 of 7, the Prepare Partition screen comes up blank, with all buttons disabled (except Next and Previous - clicking Next brings up an error message, clicking Previous is pointless).

Resolution (found at http://www.wjunction.com/showthread.php?t=21705):
Boot ubuntu up in live mode
Load synaptic package manager (System > Administration > Synaptic Package Manager)
Search for "dmraid": it should be shown as installed
Right-click and click "Mark for Removal"
Click apply and then wait for it to be removed
Proceed as normal with the installation

I have posted this here in the hope that (1) anyone else Googling for a fix will find this information
(2) maybe someone will be inclined to update the relevant part of the Ubuntu documentation, or even find and fix the root cause
I'm not too hopeful about the the last point - the guy at wjunction doesn't say how he found a fix and it is clearly not going to be easy to reproduce - now I have successfully installed Ubuntu, I no longer see the issue myself.
I suppose it is something to do with the live CD detecting a RAID controller that is not actually being used as such.

The system is a Mesh computer, about 4 years old, with a 204GB Maxtor disk on a SATA adapter (Promise FastTrak 378); the machine also has a Via VT6240 SATA RAID controller with (apparently) no disks. I have not seriously looked inside the case since I bought it off my son.
Title: Re: Prepare partitions screen comes up blank
Post by: joe12 on May 08, 2010, 03:23:08 PM
hi

 move this to the tips area

tnks
Title: Re: Prepare partitions screen comes up blank
Post by: Part_Serenity on July 18, 2010, 12:58:55 PM
After struggling with this issue and another issue for the entire day, I also hope to provide some useful insight regarding this and the "could not stat device" error.

Pretty simple fix, chuck in your LiveCD, hold down shift as it boots to access the extra boot options menu. Then press F6 and click "nodmraid", then choose the first option in this menu "Try without installing" or similar.

After this is done, follow the guide above ^ and have fun!

The key was to try them both at the same time  :P
Title: Re: Prepare partitions screen comes up blank
Post by: twisk on September 01, 2010, 11:48:23 PM
Quote
I have posted this here in the hope that (1) anyone else Googling for a fix will find this information

Thank you for trying to help.  I am trying to install Ubuntu for the first time to learn Linux, and can't due to this problem, so I can't use it.

By the way I am trying to install it into VirtualBox so I know it isn't a hardware issue.

Title: Re: Prepare partitions screen comes up blank
Post by: Mendri on January 17, 2013, 06:25:54 AM
Hi all!
It's my first post.